Issue Summary:
When setting up the Microsoft Defender connector, you may encounter the following error:
verify settings failure: collector.VerifySettings: could not build entity API base URL: parse "https://xxxxxxxxxxxxxxx.West Europe.portal.cloudappsecurity.com": invalid character " " in host name
Cause:
This error occurs because the Region field in the connector configuration is incorrectly entered with a space (e.g., "West Europe"), as you see in the screenshot below. Region cannot contain spaces.
Abstract:
To allow the required ports to use the Defender for Cloud Apps, you must enter the Region of the tenant as shown in the example below. For more information, see Microsoft Defender's network requirements doc .
EXAMPLE
When adding the connector in Snow Atlas, you can enter the regions us, us2, us3, eu, or eu2 based on the data center you are connected to.
Resolution:
To fix this issue:
- Find the correct region code using the instructions below.
- Enter the region code into the Region field of the connector configuration (no spaces, all lowercase).
- Save the connector setup.
- Test the connection to verify that it works successfully.
How to View Your Data Centre Region ?
To find your data centre:
- Go to the Microsoft Defender Portal: https://security.microsoft.com
- In the left-hand menu, select:
- Settings → Cloud Apps → System
- Click the About tab.
- In the About screen, you’ll see your region and data center location listed like the following screenshot.
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago