An installation issue has been identified when updating Adobe Acrobat Reader DC to version 21.001.20135 using the Microsoft System Center Configuration Manager deployment package. The issue occurs when the package is installed on a device while no users are logged into the system. The installation corrupts the Adobe Acrobat Reader DC file system, causing it to fail to start.
Diagnosis
If this issue occurs, you’ll see the following errors:
Windows Installer package errors
Product: Adobe Acrobat Reader DC -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action InstallWebResources, location: C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroCEF\RdrServicesUpdater.exe, command: 21.001.20135
Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action InstallWebResources, location: C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroCEF\RdrServicesUpdater.exe, command: 21.001.20135
Windows Event Viewer Application log
Event ID: 11722
Product: Adobe Acrobat Reader DC – Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action InstallWebResources, location: C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroCEF\RdrServicesUpdater.exe, command: 21.001.20135
Solution
This issue is documented in Adobe’s “known issues.” They released a patch in response. To correct this issue, utilize their hotfix patch: hotfix patch for Acrobat DC and Acrobat Reader DC.
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Case id: 00001065
Activity: Status change: 2 hours ago