Symptoms:
After a new install or upgrade of FNMEA with the Admin and Reporting modules being installed on separate servers you are able to access the Reporting tab and functions without any issues however you may notice report logs not being imported or reports not being generated, however there is no error message being shown and everything looks to be going through successfully and after reviewing the documentation and system configuration everything appears to be correct.
Diagnosis:
This is caused due to a configuration issue with the DATA directory, the DATA directory needs to be shared across both servers and both servers require access to that shared folder location in order to communicate correctly, this isn't an issue on a single box setup as the modules install using the same directory but is a step often missed on first time installs where the modules are split across multiple servers.
Solution:
Check and ensure both the Admin and Reporting modules are configured to look at the same DATA directory that will need to be shared either from one of the servers or a shared network location, in the following example the DATA directory is setup and a network share setup on the Reporting server which is shared with the Admin server.
-To do this if you open up a command prompt to the install directory as Administrator and bring up the flexnet site configurator using the following command.
Flexnet site
-On step 2 of 6 you will see below my Reporting sever is pointing to the DATA directory that has been shared as a network location for the Admin server
-When running the configurator for the Admin server you will see the DATA directory is now pointed at the shared drive that was created on the reporting server
-You will need to ensure the account running the services has access to read/write to this directory from both the Admin/Reporting servers, data should now import and reports run as expected the above changes are made
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Case id: 00001065
Activity: Status change: 2 hours ago