Summary
All agents installed are not able to refresh their policySymptoms
From a deployed beacon, the following error is found in the BeaconISS log file :2018-02-15 08:29:48,856 [mmon.BeaconPolicyCache] [ERROR] Could not load policy file from disk.
System.IO.IOException: The process cannot access the file 'C:\ProgramData\Flexera Software\Beacon\BeaconPolicy.xml' because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Flexera.Beacon.Common.BeaconPolicyCache.LoadBeaconPolicyFromDisk()
As consequence, new agents are not reporting to the App Server.
Cause
If you get the System.IO.IOException: The file exists error, it's probably because your C:/Windows/Temp folder is absolutely full with temporary files. In fact, if you have more than 65535 files in your temp folder, the method GetTempFileName will throw this error.Resolution
To resolve this, just remove all temporary files in C:/Windows/Temp. It might take some time, but it will solve the problem.After clearing files from c:\windows\temp and restarting the beacon engine service, then agents should be able to update their policy.
Was this helpful?
Related Articles
Beacon control file (policy) missing or does not contain license information, please restart the beacon interface 44Number of Views Known Issue: HTTP 500 and "Could not load file or assembly" errors may occur after upgrading a beacon to version 2020 R2.2… 39Number of Views Config.ps1 or InstallCognos.ps1 script fails with error "Could not load file or assembly 'file:///...\Support\DotNetZip.dl… 21Number of Views Could not load file or assembly 'sapnco_utils.dll' or one of its dependencies error 34Number of Views Beacon error when enabling the debug mode logging: Unable to load DLL 'SQLite.Interop.dll' 4Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago