Summary
Broken or Corrupt Trusted Storage
Symptoms
It is possible for Trusted Storage to become corrupt or broken, even with no Fulfilment Records. This differs from a standard TS break as it cannot be fixed with tsreset or any Repair request.
Cause
In this event, errors like this might be seen:
C:\temp\i86_n3>tsreset_app -reset
Performing reset operation, please wait...
Failed to reset Trusted Storage
C:\temp\i86_n3>appactutil -localrepair
ERROR: Local repair - (50044,71013,1)
Manual activation with appactutil returns:
C:\temp\clmutil>appactutil.exe -served -comm soap -commServer https://devclm.le
ica-geosystems.com/flexnet/services/ActivationService -vendordata CLM_HOSTNAME
KuCh -entitlementID B50515C00F785AA29CD0157
Generating activation request using:
Entitlement ID = B50515C00F785AA29CD0157
Expiration = 31-dec-2020
Status: 4, Creating request
ERROR: flxActAppActivationSend - (0,0,0)
There are no (visible) fulfillments in TS.
C:\temp\clmutil>appactutil -v -broken
C:\temp\clmutil>appactutil -v -long
C:\temp\clmutil>appactutil -v -valid
Resolution
To get round this navigate to this location:
C:\Documents and Settings\All Users\Application Data\FLEXnet
Then in this directory there should be a file called vendor_0xxxxx_tsf.data, where vendor= your vendor name and xxxxxx= a sequence of numbers. The '0' following the underscore represents client side TS and an 8 following the underscore represents server side TS. If you rename the file to ?vendor_0xxxxx_tsf.data_backup? or something different from the original.
Then go back and run 'tsreset_app reset' or 'tsreset_svr reset'. Ths will recreate TS and solve the issue.
Related Articles
How to View the Contents of Trusted Storage 5Number of Views How do You Repair a Trusted Storage Activation When it's in The **DISABLED** State? 5Number of Views flxActCommonLicSpcAddASRs() API Returns Error LM_TS_VIRTUALIZATION_POLICY_ MISMATCH 6Number of Views Trusted Storage Keeps Breaking 30Number of Views Broken Trusted Storage, Restore Flag Set 7Number of Views
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Case id: 00001065
Activity: Status change: 2 hours ago