Summary
This issue occurs when one of the above items is true and a compressed release is being build. A compressed release is any release that builds a single compressed setup.exe, compressed MSI, or a CD-ROM, DVD, or custom release that uses compression.Symptoms
The following may cause errors during the build process in a Basic MSI or InstallScript MSI project:
- A file has been included in the project that is larger than 2GB.
- The resulting size of a compressed CAB file in the project build is larger than 2GB.
- More than 64,000 files are being included in one CAB file.
When building a release you may encounter build errors such as -6271, -1501, the build may unexpectedly abort, or the IDE may crash.
This issue occurs when one of the above items is true and a compressed release is being build. A compressed release is any release that builds a single compressed setup.exe, compressed MSI, or a CD-ROM, DVD, or custom release that uses compression.
Cause
The Basic MSI and InstallScript MSI projects use the Microsoft Windows Installer service to perform the installation. InstallShield uses the Microsoft Cabinet SDK to compress files because the Windows Installer service supports the Microsoft CAB file format for compressed sources.
The Microsoft CAB file format has the following limitations:
- The maximum size of a single file that can be contained in a CAB file is approximately 2GB.
- The maximum number of files a single CAB file can contain is approximately 64,000.
- The maximum size of a single CAB file is approximately 2GB.
Workaround
If you need to include files that are larger than 2GB in a MSI-based project, the release settings need to be set to build an uncompressed release.
Additional Information
The following article contains information related to this issue:
-
What are the limits for a large MSI package?
Build errors -6271 and -1501 are documented in the helpnet article Build Errors and Warnings.
Related KB Articles
Q107151 Build Error 1501Related Articles
Issues caused by multiple Batch Processors. 7Number of Views Resolve User Console uninstallation error “Error Code: 9” caused by running Ux Service process 6Number of Views CVE-2025-12418: Potential Unintended File Deletion Issue Caused by InstallShield Suite Uninstallation Process 10Number of Views Known Issue: Business adapter may fail to read data from CSV file if the "Column delimiter" setting is set to "semicolon" … 38Number of Views CVE-2024-14012: Potential Privilege Escalation in InstallShield 2023 R1 3Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago