Summary
When installing a minor upgrade or small update for a multilingual setup, the language selection dialog may appear. Selecting a different language has no effect, the original language selected during the initial installation is always used.Symptoms
In past versions of InstallShield the language selection dialog could have appeared and selecting a different language had no effect,
Cause
This behavior occurs due to a Microsoft Windows Installer (MSI) design preventing new Transform (.MST) files from being applied during Maintenance Mode. Therefore based on the use of transforms and InstallShield the language cannot be changed, as each language is contained within a unique MST file.
Resolution
As indicated above, the language cannot be changed when a minor upgrade or small update is applied because of a Microsoft limitation in the MSI engine. The language selection dialog is expected to be hidden when installing a minor upgrade or small update, or when running in Maintenance Mode to eliminate confusion.
Additional Information
Related Articles
Do Snow Databases support SQL Server High Availability Group? 28Number of Views Flexera product CVE reference list (November 2025 update) 15Number of Views Revenera Product CVE Reference List (November 2025 Update) 4Number of Views Managing AWS EC2 instances with Flexera One plugins 15Number of Views How To: Perform an Offline Update using Snow Update Service (SUS) 230Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago