Summary
This article will describe a current Citrix XenApp Agent Adapter connection defect. The connection may fail with the error message "System.ArgumentOutOfRangeException: Index and count must refer to a location within the string."Symptoms
This article will describe a current Citrix XenApp Agent Adapter connection defect. The connection may fail with the error message "System.ArgumentOutOfRangeException: Index and count must refer to a location within the string."The affected version of adapter is 2016 R1 SP1 and prior version.
The error message is shown below:
016-12-23 3:15:45.088 : Informational : Worker group online server found: AAA
2016-12-23 3:15:45.150 : Error : An unhandled error occured while attempting to process the application 'Certain Application'.
2016-12-23 3:15:46.710 : Error : System.ArgumentOutOfRangeException: Index and count must refer to a location within the string.
Parameter name: count
at System.String.RemoveInternal(Int32 startIndex, Int32 count)
at System.String.Remove(Int32 startIndex, Int32 count)
at Flexera.Compliance.Importer.XenAppAgent.XaServer.GetDomainName()
at Flexera.Compliance.Importer.XenAppAgent.DataProviders.XaDataProviderBase.GetAclApplicationServers(String p_AppBrowserName)
at Flexera.Compliance.Importer.XenAppAgent.DataProviders.XaDataProviderBase.GetAclApplications()
2016-12-23 3:15:46.710 : Error : Index and count must refer to a location within the string.
Parameter name: count
at System.String.RemoveInternal(Int32 startIndex, Int32 count)
at System.String.Remove(Int32 startIndex, Int32 count)
at Flexera.Compliance.Importer.XenAppAgent.XaServer.GetDomainName()
at Flexera.Compliance.Importer.XenAppAgent.DataProviders.XaDataProviderBase.GetAclApplicationServers(String p_AppBrowserName)
at Flexera.Compliance.Importer.XenAppAgent.DataProviders.XaDataProviderBase.GetAclApplications()
at Flexera.Compliance.Importer.XenAppAgent.AclImporter.Import(String p_DatabaseConnectionString, Int32 p_DatabaseTimeout, String p_OutputFile)
at Flexera.Compliance.Importer.XenAppAgent.Program.Main(String[] args)
Cause
The current Citrix XenApp Agent adapter retrieves Citrix server by expecting a fully qualified domain name eg: AAA.flexerasoftware.comIf the server name return as short name as: AAA , the process will hit this defect and cause while connection failed.
Resolution
Current it's marked as a defect under bug FNMS-40743Workaround
Suggest User's Citrix Administratorto change the short server name into a fully qualified domain server name.Was this helpful?
Related Articles
Citrix XenApp agent may fail with error when delivery group has no users: "Object reference not set to an instance of an o… 6Number of Views Known Issue: Citrix XenApp agent may fail with error when delivery group has no users: "Object reference not set to an ins… 5Number of Views Inventory Citrix XenDesktop and XenApp using FlexNet Manager Suite 37Number of Views XenApp agent 6.0 & 6.5 not working 9Number of Views GetSAPRecommendationSet throws error in beacon-services.log: "System.ArgumentOutOfRangeException: Index was out of range. … 4Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago