Summary
When performing a compliance import this fails with the following error message ?Error: Cannot insert the value NULL into column 'FlatName', table 'Managesoft.dbo.ImportedActiveDirectoryDomain_MT'; column does not allow nulls. INSERT fails.?Symptoms
Reported in Product Version: FNMP 9.2.3, FNMS 2014, FNMS 2014 R2
When performing a compliance import this fails with the following error message, this message can be seen in the Compliance Import log file.
?Updated 20343 Active Directory users
Added 0 Active Directory users
Successfully processed in 0 seconds.
ProcessImportedActiveDirectoryComputers (Execute on FNMP)
Removed 0 obsolete Active Directory computers
Updated 10910 Active Directory computers
Added 0 Active Directory computers
Successfully processed in 0 seconds.
ProcessImportedActiveDirectoryDomains (Execute on FNMP)
Failed to execute Reader 'ProcessImportedActiveDirectoryDomains' from file C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\managesoft\ActiveDirectory.xml
Error: Cannot insert the value NULL into column 'FlatName', table 'Managesoft.dbo.ImportedActiveDirectoryDomain_MT'; column does not allow nulls. INSERT fails.
Removed 0 obsolete Active Directory domains
Updated 0 Active Directory domains
The statement has been terminated.
Added 0 Active Directory domains
All retries have been attempted for Reader 'ProcessImportedActiveDirectoryDomains'
Completed with error in 0 seconds.
FATAL: The import process has failed with the following error (use -verbose to see error details):
Error: Cannot insert the value NULL into column 'FlatName', table 'Managesoft.dbo.ImportedActiveDirectoryDomain_MT'; column does not allow nulls. INSERT fails.
Removed 0 obsolete Active Directory domains
Updated 0 Active Directory domains
The statement has been terminated.
Added 0 Active Directory domains?
Cause
This error message is caused by a known issue in the ?ActiveDirectory.xml? and has been given the reference number FNMS-2770 and is scheduled to be permanently resolved in the next release of FNMS 2014.
Resolution
The following steps can be used to resolve the issue by updating the ?ActiveDirectory.xml?.
1. Take a backup of the current database used with FNMP.
2. Take a backup of the ?ActiveDirectory.xml?, the default location for this is ?C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\managesoft\?.
3. Download the attached ?ActiveDirectoryUpdate.zip? and extract the file.
4. Replace the ActiveDirectory.xml in step 2 with the extracted file.
5. Perform a compliance import and test the issue.
Additional Information
Additional information on the issues that are resolved in a particular release can be located in the product release notes.
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Case id: 00001065
Activity: Status change: 2 hours ago