Symptoms
It is seen that after the upgrade of FNO On-premises, the devices tab is not being listed either in producer portal or in end user portal even though customer has valid licenses of FNE.
Diagnosis
FNO On-premises gets its licenses from Revenera hosted instance endpoint which is being defined in FNO under system-->configure-->Licensing.
It's observed that while checking out the licenses from the Licensing endpoint, FNO throws following error in flexnet log.
2022-03-09 22:15:00,670 [default task-18] ERROR (licensing) [ADMN] Failed to set up license source: System machine type does not match expected machine type.
It can be seen in the logs that, the machine type information which is stored in FNO Trusted storage from the previous license checkout is different than the one on which it is trying to checkout licenses now. And because of this mismatch FNO is not able to checkout license. This may be happen if VM machine type changed from Physical to Virtual or vice versa.
Solution
One can follow below steps to release the previous stored information of licenses in FNO and then refresh it with new licenses.
- Stop the FNO server.
- Take the backup of TS files usually located under "
C:\Windows\System32\config\systemprofile\.fnoStorage\ADMN" . See screenshot below for reference - Remove the TS files from the location mentioned in step 2
- Start the FNO
- Now you can see in flexnet.log that licensing threads are successful and you will be able to see the Devices tab as well.
Sample Screenshot Showing TS files:
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Case id: 00001065
Activity: Status change: 2 hours ago