Summary
An error occurs in some existing on-premises implementations of FlexNet Manager Suite when upgraded to FlexNet Manager Suite 2018 R1. This error prevents you from viewing or editing the FlexNet Manager Suite configuration in IIS.Symptoms
The issue arises when you choose to edit and then save the configuration values for FlexNet Manager Suite in Internet Information Services (IIS) Manager. An error occurs in some upgraded installations of FlexNet Manager Suite that prevents you from viewing or editing the configuration file in IIS.
The following error message is displayed in the event error log and in IIS Manager when the duplicate key is present:
The error is also visible in the event error log (if you have enabled logging for the ETW event in the Logging Configuration of IIS Manager).
Cause
The issue is caused by a duplicate key that is present in the web.config file of some upgraded installations of FlexNet Manager Suite.
Impacted versions
The following existing on-premises implementations of FlexNet Manager Suite are impacted after they have been upgraded to FlexNet Manager Suite 2018 R1:
- FlexNet Manager Suite 2015 R2 SP5
- FlexNet Manager Suite 2016 R1
- FlexNet Manager Suite 2016 R1 SP1
- FlexNet Manager Suite 2017 R1
- FlexNet Manager Suite 2017 R2
- FlexNet Manager Suite 2017 R3
Note: This error only occurs when an existing implementation of FlexNet Manager Suite is upgraded to FlexNet Manager Suite 2018 R1. It does not occur in fresh new installations of FlexNet Manager Suite 2018 R1 or later.
Resolution
The issue can be permanently resolved by completing these two tasks:
- Manually remove the duplicate key from the web.config file on the FlexNet Manager Suite web application server.
- Perform a partial IIS restart.
Task 1: Manually remove the duplicate key from the web.config file of the web application server for FlexNet Manager Suite.
Warning: Making incorrect changes to the web.config file can cause FlexNet Manager Suite to fail at start up or to stop working. Please ensure you have backed up the web.config file to another location before making any changes.
Warning: Making changes to the web.config file will cause the application pool to restart. Any active users that are currently using FlexNet Manager Suite may be interrupted, and any long running processes such as reports will be aborted. As a result, it is recommended that these changes are made outside operation hours or during scheduled downtime.
To make this change:
- On the start menu of the application server (or, in a multi-server implementation, the web application server), locate and right-click the Notepad icon and select Run as administrator.
- Open the web.config file located in the WebUI folder of the FlexNet Manager Suite install folder. The default location for this file is C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\WebUI.
- Search for lines that starts with <add key="aspnet:MaxHttpCollectionKeys which is located under the <appSettings> XML node.
- Preserve just the first of these lines, and remove any duplicates that you find. An example XML element is <add key="aspnet:MaxHttpCollectionKeys" value="5000" />, but you should remove duplicates even if the value is different.
- Save the file and close the text editor.
Task 2: Perform a partial IIS restart
Recommendation: Once the web.config file has been updated, it is recommended that a partial IIS restart be performed on the application pool by default called FlexNet Manager Platform on the web application server.
To perform this restart:
- Navigate to IIS > Sites > Default Web Site > Suite. Note: If you have renamed the Default Web Site in IIS, modify this path accordingly.
- In the Actions pane, click Basic Settings.
- In the Edit Application window, locate and record the name of the application pool listed in the Application Pool field. The default name is FlexNet Manager Platform.
- Click Cancel.
- Navigate to Application Pools to view a list of application pools on this server.
- Select the application pool identified in step 3 above. For example, FlexNet Manager Platform.
- In the Actions pane, click Stop to stop the application pool and then click Start to restart the application pool.
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Case id: 00001065
Activity: Status change: 2 hours ago