Summary
This error indicates a generic failure returned from Fusion while attempting to install a .NET assembly in to the Global Assembly Cache or the Win32 GAC (WinSxS).Symptoms
At runtime, you see the following error:
- Error 1935. An error occurred during the installation of assembly component {COMPONENT_GUID}. HRESULT: ERROR_CODE
Where COMPONENT_GUID is the guid of a component in your MSI package that contains a .NET assembly and ERROR_CODE is the HRESULT passed back. Often times these messages contain information relating to your .NET assembly that includes Publick Key Tokens, Processor Architecture, etc.
Cause
This error indicates a generic failure returned from Fusion while attempting to install a .NET assembly in to the Global Assembly Cache or the Win32 GAC (WinSxS).Workaround
Because the error is generic and only indicates that something failed, there are extra steps that will have to be taken in order to debug this problem. Before you begin to heavily debug this issue, it's first important to ensure that the .NET properties being used to install your assembly (such as ProcessorArchitecture, PublicKeyToken, Version) are what the .NET assembly requires. If this is not the case, then changing them to be the appropriate value from your build environment should resolve those types of issues.
The first step is to decode the HRESULT code that was returned through the error message. This will indicate the type of failure and possibly suggest the reason why it failed.
The second step is to determine the component that caused the error. This will allow you to pinpoint whether it is a component you are installing or a merge module (such as the Microsoft Visual C++ Runtimes) that is causing this error.
After doing those two steps, following the directions indicated by Aaron Stebner in his blog should point you in the right direction:
Additional Information
You can read more of Aaron Stebner's various bloggings here:
Aaron Stebner's WebLog
Aaron Stebner's WebLog
For more information on decoding HRESULT codes, please reference this article:
Aaron Stebner also has a unified .NET Troubleshooting guide here:
Was this helpful?
Related Articles
An error occurred while attempting to automatically activate registration Activator 251Number of Views Microsoft Access Runtime 365 may crash when used by MGSBI to read data to be imported from files 12Number of Views Setting the JVM Heap Size at Runtime 4Number of Views PowerShell Custom Actions Failing at Runtime 3Number of Views Runtime Error: Failed to load CLR - Error 0x80131700 12Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago