Symptoms
These are some indications that the Perforce client is not installed:
- After you have defined the settings for a Perforce instance in Code Insight, the test used to check your Perforce connection fails. (The Perforce instance is defined and tested from Manage Project > Edit Project > Version Control Settings on the project's Summary page.)
- Attempts to scan the project codebase fail.
Diagnosis
The Perforce client is not installed on the machine where the FlexNet Code Insight server is running.
Solution
You must install the Perforce client on the machine where the Code Insight server is running.
The following procedure provides basic steps for installing the Perforce client. For more information, refer to the Perforce documentation such as found on these sites:
- https://www.perforce.com/perforce-packages
- https://www.perforce.com/manuals/p4sag/Content/P4SAG/install.linux.packages.install.html
To install the Perforce client, do the following:
- Execute the following command to add Perforce's packaging key to your RPM keyring:
sudo rpm --import https://package.perforce.com/perforce.pubkey - Add Perforce's package repository to your YUM configuration. To do so, simply create a file called /etc/yum.repos.d/perforce.repo with the following content:
[perforce]
name=Perforce
baseurl=http://package.perforce.com/yum/rhel/{version}/x86_64
enabled=1
gpgcheck=1
Replace {version} in the baseurl with either 6 (for RHEL 6) or 7 (for RHEL 7). - To install the Perforce client package, run this command:
sudo yum install helix-cli.x86_64
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