Question
Hostname Specified in license file is not available in the local network database. When can licensing administrator encounter this error on server startup?
Answer
Root Cause
Non Standard characters in the hostname. For ex: localized languages (Japanese, Chinese, Turkish, Hebrew, Arabic, etc) and also including many European languages using non-standard letter like Ä/ä, Ö/ö, Ü/ü.
This is a known issue. It is a limitation rooted in standards.
RFC-952, as modified by RFC-1123, permits only A-Z, 0-9 and - in a hostname. We won't be contravening this spec by trying to support additional chars in hostname.
On startup, the license server is unable to resolve such a hostname.
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago