Summary
When attempting to launch InstallShield using a concurrent license, sometimes InstallShield is able to successfully check out a license; other times, one of the errors described below appears.
Symptoms
When attempting to launch InstallShield using a concurrent license, sometimes InstallShield is able to successfully check out a license; other times, one of the following error appears:
InstallShield could not acquire a license because you are not entitled to use this software. You can try to reestablish the connection or exit InstallShield. Contact your license administrator for details.
License error: Cannot connect to license server system. (-15,570)
Cause
One known cause of this problem is that the connection between InstallShield (the FLEXenabled application) and the FLEXnet License Server has timed out.
Resolution
The environment variable FLEXLM_TIMEOUT can be used to set the timeout value for FLEXenabled applications when it attempts to connect to a license server port in the range 27000?27009.
The FLEXLM_TIMEOUT environment variable is documented in License Administration Guide or End User Guide as follows.
Windows only: Sets the timeout value a FLEXenabled application uses when attempting to connect to a license server port in the range 27000?27009. Values are in microseconds, within the range 0?2,147,483,647. The default setting is 100,000 microseconds.
To decrease the occurrence of connection timeouts, increase the value of the FLEXLM_TIMEOUT environment variable by 1000000 microsecond increments until the connection to the License Server is successful. (i.e., FLEXLM_TIMEOUT = 300000 will set the timeout value to 3 seconds).
Additional Information
If InstallShield consistently fails to check out a license, please refer to the related Knowledge Base article, InstallShield Fails to Connect to License Server.
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
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Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago