Summary
This article discusses the "unzip: not found" and "Invalid unzip command found" error messages when installing to a Linux or Solaris machine
Symptoms
When running an installer targeted for Linux or Solaris, the following errors appear during launch:
unzip: not found
Invalid unzip command found
Cause
When running an installer (with a Linux or Solaris build target) on Linux or Solaris, a valid copy of the system unzip command is required for the installer to launch.
InstallAnywhere scripts are written to look for a valid unzip command to be present on UNIX-based platforms. Once the unzip command is installed, it has to be made part of the PATH variable to be available. The InstallAnywhere installer scripts look for the unzip command in the following locations:
- /usr/bin
- /usr/sbin
- /usr/local/bin
- [directory defined by the PATH variable]
If the unzip command is not found in any of those locations, then installers fail to launch.
Resolution
If the unzip tool is not present, you need to install the unzip command by either downloading it here or by running the apt-get update or apt-get install commands.
Additional Information
The following are required on UNIX-based platforms:
- Unzip tool? It is mandatory that all UNIX-based platforms have a valid unzip command/tool installed and be made available on PATH in order to support extraction of installers /jre for the installers to launch. If it is not present, the JVM search settings configured in the InstallAnywhere project will not be respected. For more information, see above.
- wget tool? If the user chooses to download a JVM on a UNIX-based platform, a wget tool is required.
- tar, gzip, and unzip tools?For extracting the downloaded JVM on UNIX-based platforms, the tar, gzip, and unzip tools are required.
- md5sum tool? For MD5 checksum verification of a downloaded JVM on UNIX-based platforms, the md5sum tool is required.
Related Articles
Agent services may fail to start on Suse Linux servers with error: "/etc/init.d/ndtask: line 181: daemon: command not found" 6Number of Views Intune adapter may fail in Reader 'Get Intune Users' with error: "CsvHelper assembly not found. Please upgrade the Beacon … 19Number of Views Snow Agent for Unix: “command not found” error when performing scan 28Number of Views Command to install licensing service in Windows and Linux 10Number of Views Resolve “ORA-01017: invalid username/password; logon denied” errors in Snow Inventory Oracle Scanner 24Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Revenera Assistant
Case id: 00001065
Activity: Status change: 2 hours ago