Summary
A failure error occurs during the inventory import/reconcile with an error similar to the following:
Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Symptoms
FATAL: Import failed. Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at ManageSoft.Database.DatabaseCommand.ExecuteNonQuery() at ManageSoft.Database.Impl.DatabaseLayerBaseSql.Execute(CommandType p_CommandType, String p_CommandText, DatabaseParameter[] p_Parameters) at ManageSoft.Database.Impl.DatabaseLayerBase.Execute(String p_StoredProcedure, DatabaseParameter[] p_Parameters) at ManageSoft.Compliance.Database.Impl.Procedures.LicenseAssignmentResetToEasyLicenses() at ManageSoft.Compliance.Importer.Procedures.ManageSoft.LicenseReconcile.RunSQLLicenseReconcile() at ManageSoft.Compliance.Importer.Procedures.ManageSoft.LicenseReconcile.ReconcileLicenses()
Cause
By default, the compliance importer is set to run for approximately 10 minutes per procedure and the full import will run for a total of 2 hours. If there are large amounts of data to process in a particular procedure (for example, file evidence or usage data), then it can timeout and close the connection.
Resolution
- Open the registry on the FNMP server
- On 32bit systems - Navigate to [HKLM\Software\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
- On 64bit systems - Navigate to [HKLM\Software\Wow6432Node\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
- Create the below registry key
- Type: REG_DWORD
- Name: CommandTimeout
- Value: Decimal value for seconds (eg: 28800 = 8 hours)
This value can be changed as required. In relation to time, 14,400 seconds equates to 4 hours and 28,800 seconds is 8 hours, etc.
Additional Information
If your FNMP server is a 64 bit OS then the registry key is [HKLM\Software\WOW6432Node\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
Related Articles
Known Issue: “Calculating consumptions for licenses from devices with history” license reconcile step may fail with error … 18Number of Views IBM PVU sub-capacity license calculations may default to full-capacity when all inventory is imported from IBM approved so… 38Number of Views SWACC inventory files containing Client Access License (CAL) access detail may fail to be processed with error: "Invalid l… 11Number of Views Import writers step "Syncs the reconcile staging tables to main tables" step may fail with error: 'The INSERT statement co… 10Number of Views "Sync License Reconcile Results" reconcile step may generate invalid license assignments and fail: "Violation of PRIMARY … 5Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago