Summary
When FlexNet Manager Suite is upgraded to 2022 R1 or later and Microsoft SQL Server was upgraded to SQL Server 2017 or later, the following error may occur:
Running cm-migr1300-ComplianceSchema.sql...100% Running cm-migr1300-CompliancePreCLRInstall.sql...50% There was an error while attempting to run 'cm-migr1300-CompliancePreCLRInstall.sql'. An error occurred in the Microsoft .NET Framework while trying to load assembly id 65538. The server may be running out of resources, or the assembly may not be trusted. Run the query again, or check documentation to see how to solve the assembly trust issues. For more information about this error: System.IO.FileLoadException: Could not load file or assembly 'sqlproceduresclr, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An error relating to security occurred. (Exception from HRESULT: 0x8013150A) System.IO.FileLoadException: at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection) at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) at System.Reflection.Assembly.Load(String assemblyString)
Diagnosis
The issue occurs because the older versions of SQLProceduresCLR.dll are signed with an older Flexera code signing certificate which is now expired. The newer versions are signed with an updated certificate, which the customer may have already imported into the database server.
Since the old certificate may not exist in the database, the SQL Server treats that assembly as "not secure" and it does not allow the installation.
Solution / Workaround
The solution is to add the old certificate to the database. This needs the old as well as the new code signing certificates in the database, so that the migration runs successfully.
- If only the latest Flexera code signing certificate is imported on the database server:
Download the Old Flexera Signed Security Certificate 2021 for SQL Server 2017 and 2019.zip and follow the steps mentioned in the readme.txt.
- If no Flexera code signing certificate is imported on the database server:
Download the All Flexera Signed Security Certificates for SQL Server 2017 and 2019.zip and follow the steps mentioned in the readme.txt.
Fix status
This issue is planned to be addressed in the following future FlexNet Manager Suite releases: 2024 R2 (On Premises), FNMS Cloud N/A
Other information
Affected components: Database
Master issue ID: IOK-1001941
Also known as: ITAM-677
Related Articles
Restore FlexNet Manager Suite databases on a new SQL Server instance 61Number of Views Database migration may fail during upgrade if SQL Server instance does not have certificates installed to cover all FlexNe… 5Number of Views SQL Server edition not recognized if SQL Server WMI provider is inaccessible 114Number of Views BMC Discovery import may fail with error if SQL Server database compatibility level is below 130: "Invalid object name 'ST… 7Number of Views Step 10001 in the im-mig1230-migpost.sql inventory database migration script may fail with error: "Violation of PRIMARY KE… 4Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago