Summary
Custom Action message box loses focus behind another open window on Windows 7Symptoms
When spawning a Windows Form or Message Box from a Managed Code custom action, the spawned Window or Message Box loses focus and is behind the other open windows on a Windows 7 machine.
The same Custom Action will keep the spawned window in the foreground on any other operating system.
Cause
This behavior is related to the changes made in the Windows 7 Operating System.Resolution
To resolve this issue, please use the Windows GetForegroundWindow function or the SetForegroundWindow function in the Managed Code assembly, that you are trying to launch from a Managed Code Custom Action.
Here is a sample code, on how to use the SetForegroundWindow method in a VB .Net application -
Private Sub myform_Shown(ByVal sender As Object, ByVal e As
System.EventArgs) Handles Me.Shown
Dim hWnd As IntPtr = Me.Handle
If IsNothing(hWnd) = False Then
BringMeForward(hWnd)
Else
MsgBox("No Window Handle!")
End If
System.EventArgs) Handles Me.Shown
Dim hWnd As IntPtr = Me.Handle
If IsNothing(hWnd) = False Then
BringMeForward(hWnd)
Else
MsgBox("No Window Handle!")
End If
End Sub
Friend Sub BringMeForward(ByVal hWnd As IntPtr)
Dim bSet As Boolean = SetForegroundWindow(hWnd)
End Sub
Additional Information
For more information about the GetForegroundWindow function, please refer to this msdn article --> GetForegroundWindow Function
For more information about the SetForegroundWindow function, please refer to this msdn article -->
For more information about this issue, please refer to this msdn community thread --> http://social.msdn.microsoft.com/Forums/pl-PL/vclanguage/thread/5f54c9ac-5517-4809-b0b9-7c81684b71e0
Was this helpful?
Related Articles
Writing to the Log File from a Custom Action in an MSI 13Number of Views HOW TO: Stop a Windows Service using a Custom Action 8Number of Views Problem: Lost Connection to Custom Action Server Process. Attempting to Regenerate. 5Number of Views Custom Action Can Fail on Windows Vista If ALLUSERS Is Not Set 3Number of Views PowerShell cmdlet get-property Used in a Custom Action 6Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago