Summary
Gathering inventory from Oracle VM Manager may fail if an Oracle VM server is not a member of a server pool.
Symptoms
A symptom of this problem occurring is a generic generic failure result appearing in inventory rule status files similar to the following:
<TaskStatus Result="Failed" StartDateTime="2021-09-22T15:52:35" Type="OracleVMInventory" Status="OVMManagerInventoryFailed" Duration="8.09"/>
Be aware that a generic failure like this may also be a symptom of a different problem - this result is not specific to this issue.
Cause
The Oracle VM Manager inventory gathering process expects that all servers are a member of a server pool, and aborts the gathering inventory process with a failure if a server without a server is found without a server pool.
Resolution
If you believe this issue may be affecting you, contact Flexera Support to enquire about the availability of a hotfix or workaround suitable for your environment.
Additional details
When this issue occurs, tracing such as the following is produced when running the problematic Oracle VM Manager inventory gathering operation with the +Scheduling/RemoteExecution trace class enabled through etdp.trace configuration:
2021-09-22 05:52:41.856Z, pid 12956, thread 8716 (Scheduling/RemoteExecution/Common): Collecting inventory from OVM Manager host '10.68.240.64' with account 'OVM inventory account' 2021-09-22 05:52:43.466Z, pid 12956, thread 8716 (Scheduling/RemoteExecution/Common): Failed to generate Oracle VM Manager inventory: 0x80004003 2021-09-22 05:52:43.466Z, pid 12956, thread 8716 (Scheduling/RemoteExecution/Agent/Threads): Result XML = <TaskStatus Result="Failed" StartDateTime="2021-09-22T15:52:35" Type="OracleVMInventory" Status="OVMManagerInventoryFailed" Duration="8.09"/>
Related Articles
Known Issue: Oracle VM Manager inventory task fails when server is not part of server pool (IOJ-2226007) 4Number of Views Unable to inventory Oracle VM Manager (OVMM) servers due to TLS incompatibilities 8Number of Views IBM PVU and VPC licenses may not be consumed for Oracle VMs where inventory is gathered by both the FlexNet inventory agen… 4Number of Views Very limited diagnostic information available from the Oracle VM Manager inventory process 4Number of Views Check the Oracle database connection from the Inventory Manager and Inventory Beacon servers 24Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago