Summary
During Offline Activation of InstallShield 2010, after saving the License Request file and clicking the Next button, a dialog states that Activation has been successful. However, when InstallShield 2010 is launched, start-up fails with an error stating the product is not activated.Symptoms
During Offline Activation of InstallShield 2010, after saving the License Request file and clicking the Next button, a dialog states that Activation has been successful. However, when InstallShield 2010 is launched, start-up fails with an error stating the product is not activated.
Cause
When performing Offline Activation, after generating the request code, the product does not save its state as in offline activation state. Upon restart, no dialog appears to accept the response code. This leaves the InstallShield 2010 product inactivated, even though the activation process states it completed without error.Steps To Reproduce
Perform offline activation of InstallShield 2010 on a system running Windows 7.
Workaround
There are two options for working around this issue:I) Activate online
II) Activate offline following this procedure:
- Select the 'Proceed with Offline Activation' option
- Email Flexera Software the generated Request Code
- Wait for a return email containing the Response Code
- Download and uncompress the .zip file found in the attachments section of this Knowledge Base article
- Run the Offline.reg file by double clicking on the file from within Windows Explorer. This will place a key value in your registry.
- Reopen the InstallShield 2010 IDE
- When prompted for the response code, paste in the Response Code contained in the returned email.
Additional Information
This problem is being tracked internally by issue IOB-000058716, and a fix will be released with a later version of the product.Related KB Articles
Q209194Was this helpful?
Related Articles
Performing Offline Activation of InstallShield 2009 Express Fails to Activate the Product 4Number of Views How Perform Offline Activation of Snow License Manager 25Number of Views Activation of InstallShield 2010 using an AdminStudio 9.5 serial number results in Serial Number Not Registered Error 20661 7Number of Views How To Return To The Online Activation Method From The Offline Activation Method 14Number of Views How to Activate an InstallShield Node-Locked License 7Number of Views
Revenera Assistant - Beta
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago