Summary
This provides a resolution for Detector hangs on launch.Symptoms
FlexNet Code Insight Detector becomes unresponsive upon launching, and the file tree panel says "Please wait. Reloading the filesystem ..."
Cause
There are too many namespaces (jar/class files) in the scan results.
Resolution
-
Rescan the workspace with namespace matching disabled from the Workspace Settings page:
-
Before you rescan, you can run and download a copy of the Third-Party Indicators Report to have an archive of the namespace results.
- Alternatively, you can split up the jar/class files into multiple workspaces.
Workaround
Prior to the rescan, you may wish to increase the Detector Heap Size in the 'My Settings' page to ensure that the detector is given more memory to attempt to increase the amount of processed namespaces prior to this failure.Was this helpful?
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Case id: 00001065
Activity: Status change: 2 hours ago