Summary
The following error may occur when running a reconcile. This article contains a description of the issue and possible resolutions. "Error: The instance of the SQL Server Database Engine cannot obtain a LOCK resource at this time. Rerun your statement when there are fewer active users. Ask the database administrator to check the lock and memory configuration for this instance, or to check for long-running transactions."Symptoms
You may see the following error message displayed in the Importer log:
2018-01-16 05:42:34,348 [INFO ] Failed to execute Writer 'DeleteUnrequiredInstalledFileEvidence' from file E:\FNMSProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Writer\FileEvidence.xml, at step line 13 Error: The instance of the SQL Server Database Engine cannot obtain a LOCK resource at this time. Rerun your statement when there are fewer active users. Ask the database administrator to check the lock and memory configuration for this instance, or to check for long-running transactions. 2018-01-16 05:42:34,348 [INFO ] All retries have been attempted for Writer 'DeleteUnrequiredInstalledFileEvidence' 2018-01-16 05:42:34,363 [ERROR] System.Data.SqlClient.SqlException (0x80131904): The instance of the SQL Server Database Engine cannot obtain a LOCK resource at this time. Rerun your statement when there are fewer active users. Ask the database administrator to check the lock and memory configuration for this instance, or to check for long-running transactions.?
Cause
Possible causes of this issue:
- A reconcile was running and changing DB data at the same time a Web UI user changed the same table. For example when the license reconcile is running and updating licenses, if a user was to save a license this can stop the reconcile as the lock will be held by the Web UI user.
On-premise only:
- Database settings are not set correctly according to the product specifications, for example if a database is set to a FULL recovery model instead of SIMPLE. To confirm the settings use the following query:
SELECT * FROM sys.dm_exec_requests CROSS APPLY sys.dm_exec_sql_text(sql_handle) SELECT * FROM sys.sysprocesses WHERE open_tran = 1 SELECT * FROM sys.databases DBCC SQLPERF(logspace)
- SQL Server memory allocation has not been configured to have enough resources.
- SQL Server affected by a known bug in certain versions (see the Microsoft link in the Additional info section below).
Resolution
Firstly, re-run the reconcile and confirm if the issue can be reproduced. It may be advisable to run this when the system is expected to be idle and to change the scheduled job as necessary. If the issue reoccurs it will need further investigation by engineering. For Cloud customers, there can be limited troubleshooting beyond attempting to re-run a reconcile - so contact support for assistance if still continuing issues.
To adjust the database settings (for recovery model, etc):
- Open SQL Server Management Studio and connect to the relevant instance.
- Right-click the DB and click Properties.
- Click the Options tab.
To adjust SQL Server memory allocation:
- Open SQL Server Management Studio and connect to the relevant instance.
- In Object Explorer, right-click a server and select Properties.
- Click the Memory node.
- Under Server Memory Options, enter the same amount that you want for Minimum server memory and Maximum server memory.
- Use the default settings to allow SQL Server to change its memory requirements dynamically based on available system resources. It is recommended to set a max server memory as detailed above.
Additional Information
Effects of min and max server memory: https://technet.microsoft.com/en-us/library/ms180797(v=sql.105).aspxFIX: Performance problems occur when database lock activity increases in SQL Server: https://support.microsoft.com/en-in/help/2926217/fix-performance-problems-occur-when-database-lock-activity-increases-i
Was this helpful?
Related Articles
Restore FlexNet Manager Suite databases on a new SQL Server instance 61Number of Views BMC Discovery import may fail with error if SQL Server database compatibility level is below 130: "Invalid object name 'ST… 7Number of Views Known Issue: EvidenceAlerts import writer step may fail with error when using SQL Server 2016: INSERT EXEC failed because … 12Number of Views Database migration may fail during upgrade if SQL Server instance does not have certificates installed to cover all FlexNe… 5Number of Views Known Issue: Database migration may fail if database is restored on to a SQL Server 2017 (or later) instance that does not… 23Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago