Symptoms:
With SCCM import, the reconcile fails with an error similar to the one below:
Failed to execute Reader 'GetUniversalApplicationInstalledInstallerEvidence-CreateIndexes' from file C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\sms\InstallerEvidence.xml, at step line 2 Error: Operation failed. The index entry of length 910 bytes for the index 'IX_InstallerEvidence' exceeds the maximum length of 900 bytes. Warning! The maximum key length is 900 bytes. The index 'IX_UniversalInstalledInstallerEvidence' has maximum length of 1056 bytes. For some combination of large values, the insert/update operation will fail. Warning! The maximum key length is 900 bytes. The index 'IX_InstallerEvidence' has maximum length of 1056 bytes. For some combination of large values, the insert/update operation will fail. The statement has been terminated.
Diagnosis:
This is due to the combined string of the installer evidence, version, and publisher being too long.
This usually occurs if the any of the above values are modified or the installation was repackaged.
Solution:
This issue has bee resolved in FNMS 2019 R2.3.
Workaround:
The queries below can be used on the SCCM database to identify which entry and machine this evidence is coming from.
If possible, please remove the evidence. If it is modified from the default value, there is a high chance this will not map to any existing entry in the library.
SELECT DATALENGTH(DisplayName0) + DATALENGTH(Version0) + DATALENGTH(Publisher0), c.name00, arpd.* FROM dbo.v_GS_ADD_REMOVE_PROGRAMS AS arpd LEFT OUTER JOIN Computer_System_data AS c ON c.MachineID = arpd.ResourceID WHERE DATALENGTH(DisplayName0) + DATALENGTH(Version0) + DATALENGTH(Publisher0) > 900 SELECT DATALENGTH(DisplayName0) + DATALENGTH(Version0) + DATALENGTH(Publisher0), c.name00, arpd.* FROM dbo.v_GS_ADD_REMOVE_PROGRAMS_64 AS arpd LEFT OUTER JOIN Computer_System_data AS c ON c.MachineID = arpd.ResourceID WHERE DATALENGTH(DisplayName0) + DATALENGTH(Version0) + DATALENGTH(Publisher0) > 900
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
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Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago