Summary
Red Hat Enterprise Server and SuSE Linux Enterprise are not detected as installed applicationSymptoms
Environment:- Inventory source: FlexNet Manager Suite (Agent)
- Operating System: Red Hat Enterprise Linux, SuSE Linux Enterprise
Thus, the Linux operating system does not exist in the Applications tab of Inventory Device Properties of the Red Hat Enterprise Server or SuSE Linux Enterprise Server installed computers.
Cause
FlexNet Manager Suite maps the recognized specific name to a simple name using the definition in OSNameMap.txt file. The file is stored in "<Flexnet_Manager_Platfom_Installed_folder>\Reporter"The following is full MGS_OperatingSystem class in a ndi file which was collected from the Red Hat Enterprise Linux Server 7.1 running computer. The Caption attribute "Red Hat Enterprise Linux Server 7.1 (Maipo)" is converted to "Red Hat Linux" due to the definition "^Red\sHat.* Red Hat Linux" in OSNameMap.txt when the ndi file is imported to the Inventory database.
<Hardware Class="MGS_OperatingSystem" Name="Linux" Evidence="OS API">
<Property Name="CSName" Value="enrhlinux71"/>
<Property Name="Caption" Value="Red Hat Enterprise Linux Server 7.1 (Maipo)"/>
<Property Name="FreePhysicalMemory" Value="183400"/>
<Property Name="FreeVirtualMemory" Value="2097148"/>
<Property Name="Kernel" Value="Linux"/>
<Property Name="KernelRelease" Value="3.10.0-229.el7.x86_64"/>
<Property Name="LastBootUpTime" Value="20170929T034817Z"/>
<Property Name="Manufacturer" Value="Unknown"/>
<Property Name="Name" Value="Red Hat Enterprise Linux Server"/>
<Property Name="OSArchitecture" Value="64-bit"/>
<Property Name="OSType" Value="36"/>
<Property Name="TotalVirtualMemorySize" Value="2097148"/>
<Property Name="TotalVisibleMemorySize" Value="1884696"/>
<Property Name="Version" Value="7.1"/>
</Hardware>
<Property Name="CSName" Value="enrhlinux71"/>
<Property Name="Caption" Value="Red Hat Enterprise Linux Server 7.1 (Maipo)"/>
<Property Name="FreePhysicalMemory" Value="183400"/>
<Property Name="FreeVirtualMemory" Value="2097148"/>
<Property Name="Kernel" Value="Linux"/>
<Property Name="KernelRelease" Value="3.10.0-229.el7.x86_64"/>
<Property Name="LastBootUpTime" Value="20170929T034817Z"/>
<Property Name="Manufacturer" Value="Unknown"/>
<Property Name="Name" Value="Red Hat Enterprise Linux Server"/>
<Property Name="OSArchitecture" Value="64-bit"/>
<Property Name="OSType" Value="36"/>
<Property Name="TotalVirtualMemorySize" Value="2097148"/>
<Property Name="TotalVisibleMemorySize" Value="1884696"/>
<Property Name="Version" Value="7.1"/>
</Hardware>
The ARL defines the WMI evidences of Red Hat Enterprise Linux 7.1 Server as below, therefore the converted Caption value "Red Hat Linux" does not match the defined evidence.
Resolution
The definitions in OSNameMap.txt can be commented out to disable the conversion of Caption attribute value of MGS_OperatingSystem class if you add "#" in the beginning of the line.Re-generate and re-import .ndi files of Linux servers are required after updating OSNameMap.txt.
Full steps are: ( step 1 and 2 are optional, it is for clean-up the current imported data )
- Delete Linux servers in All inventory.
- Delete Linux servers in All Discovered Devices.
- Open "<FlexNet Manager Platform>\Reporter\OSNameMap.txt" file via text editor.
- Commented out the following line
Before:
^Red\sHat.* Red Hat Linux
^S[Uu]SE.* SuSE Linux
^S[Uu]SE.* SuSE Linux
After:
# ^Red\sHat.* Red Hat Linux
# ^S[Uu]SE.* SuSE Linux
# ^S[Uu]SE.* SuSE Linux
- Save the file
- Run inventory schedule.
- Wait for importing new inventory files into FNMS application server.
- Run Reconcile with the Update inventory for reconciliation.
Additional Information
The issue has identified as Bug #FNMS-35341 "OSNameMap.txt should not modify Linux or OSX evidence"
Related KB Articles
Redhat OS just says Redhat Linux, no version and editionWas this helpful?
Related Articles
Installer User Interface Mode Not Supported Error on Red Hat Enterprise Linux 7.3 & 7.4 6Number of Views Agent installation fails attempting to create symlinks on Red Hat Enterprise Linux 9 if chkconfig is not installed 4Number of Views Configuring Red Hat Licenses in FlexNet Manager 10Number of Views Various OSes (including SUSE Enterprise Linux (SLES), IBM i and Win2019) are not classified as a "server" OSes for FlexNet… 4Number of Views Authentication error when attempting to enable Windows Authentication and connect to AdminStudio via Enterprise server tab 12Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago