Summary
The cause of a Runtime Error 1310Symptoms
When running an installing, error 1310 occurs:
Error 1310: Error writing to file [1]. Verify that you have access to that directory
[1] is the file that is over 2GB in size.
Cause
This is a Microsoft limitation with Windows 7 and the MSI technology. If you include a file that is over 2GB in size you will get this error when trying to install.
Workaround
Please try the following possible workaround to copy your 2+ GB file to the target machine:
-
In the Support Files > Advanced Files view, add your file under the Disk1 folder
-
Create a custom action that would copy this file to the target location. The Disk1 folder can be referenced as SourceDir. Note that the release would have to be built uncompressed for SourceDir to resolve to the Disk1 folder. Building an uncompressed setup is also a requirement if you include a file that is larger than 2GB since Microsoft's cab extraction utility has this size limit
-
Remove the file from your component
Basically, rather than installing the file as part of a component, you would create a custom action that would copy the file from the source location (disk) into the target folder. If using an InstallScript custom action, the function XCopyFile can be used. In order to get the value of SourceDir and INSTALLDIR and use them in InstallScript custom action, you would need to use the MsiGetProperty function.
Related Articles
Windows Installer Error 1310 3Number of Views Runtime Error: Failed to load CLR - Error 0x80131700 12Number of Views App Portal Server Error in '/ESD' Application Runtime Error 13Number of Views Runtime Error 50041 Failed to Connect to the License Server 4Number of Views Operations Manager: Runtime error when starting Operations Manager Admin Client 5Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago