Symptoms:
When login into the End User Portal using the bulk entitlements web register key, it is giving a message "No products are available for download at this time. Please check again later" although the bulk entitlement has a valid product associated with a valid download package and files.
Diagnosis:
This is an expected application behaviour as per current FNO design. If the web-reg key is not registered with a user and an account FNO won't list the downloads and it will show the message like below screenshot.
Solution:
To list the download a user must do "Self Registration" from End-user portal using the provided web-reg key and his email ID. Once the registration is complete, it will create a self-registered account for the user and will link the downloads to the user's account which will, in turn, make the downloads available for the user or anyone else who is login into the End User Portal with the registered "Web Register key".
Below Screenshot shows the Register button in the End User Portal:
Once the Registered button is clicked it will take you to the below Form to register as mentioned earlier:
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Case id: 00001065
Activity: Status change: 2 hours ago