Summary
The installed application recognition library (ARL) is incompatible with this release of FlexNet Manager Platform error message is displayed when lanuching the console.Symptoms
The following error might occur when a user starts a FNMP remote console or admin console:
The installed application recognition library (ARL) is incompatible with this release of FlexNet Manager Platform. Manually run the scheduled task "Import ManageSoft application recognition library" on your FlexNet Manager Platform server to update the ARL before starting the console. A screenshot of the error message is below:

Cause
This is due to an ARL staging table "ARLStagingSoftwareTitleVersion" were not created in FNMP database if ARL update failed for some reason. Please note not all ARL update failure will result in this error, it only happens for some rare and yet to be identified corner cases.Resolution
Please apply the SQL script in the attached "public_create_ARLStagingSoftwareTitleVersion_table.txt" to your FNMP database. Reopen the admin console and remote console, this error should not be present anymore.Was this helpful?
Related Articles
Where can I access end of support life (EOSL) data for applications in the application recognition library (ARL)? 7Number of Views A vulnerability exists in FlexNet Manager Suite release 2015 R2 SP3 and earlier (including FlexNet Manager Platform 9.2 an… 8Number of Views Why some SQL Server components such as Reporting Service / Integration Service / Analysis Service are classified as Commer… 8Number of Views "Import ManageSoft application recognition library" scheduled task fails with 0x1 error code 5Number of Views Install the SAP connector libraries for SAP integration with FlexNet Manager Suite versions 2023 R1 or above 37Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago