Summary
Val0008 infoSymptoms
When performing Upgrading and Patching Validation, a validation error may occur in one of the following formats:
-
"ISDEV : error Val0008 In the Upgrade table, the Action Property [1] is not listed as a member of SecureCustomProperties. The defined upgrade may not function properly."
-
"ISDEV : error Val0008 In the Upgrade table, the Action Property [1] is not public. The defined upgrade will not function properly."
-
"ISDEV : error Val0008 In the Upgrade table, the Action Property [1] is already defined in the property table. The defined upgrade will not function properly."
-
"ISDEV : error Val0008 In the Upgrade table, the Action Property [1] is used more than once. This may cause undesirable results at runtime."
-
"ISDEV : error Val0008 In the Upgrade table, there exists a record where the MaxVersion [2] is less than the MinVersion [3]. This will cause unpredictable results at run time."
[1] is a placeholder that contains the name of the Action Property specified in the Upgrade table. [2] and [3] contain version numbers specified in the Upgrade table.
Cause
This is a validation error that only applies to major upgrades and ensures the integrity of the ActionProperty and Version elements of all records in the Upgrade table.
Resolution
To resolve this validation error, follow these steps for your specific instance of the error message.
- Select the Property Manager view.
- Click in the last row of the list of properties to create a new row.
- Type SecureCustomProperties in the Name column. (Note: This is case-sensitive.)
- Enter the value specified as the Action Property in the error message in the Value column.
- Rebuild the project.
- Select the Direct Editor view.
- Select the Upgrade table in the center column.
- Note the ActionProperty column in this table.
- Make sure all values in this column appear in all capital letters.
- If any have lower-case characters, change them to all capital letters.
- Rebuild the project.
- Select the Direct Editor.
- Select the Upgrade table in the center column.
- Note the ActionProperty column in this table.
- Locate the value specified in the error message and change it to a new value, such as TEST.
- Rebuild the project.
- Select the Direct Editor view.
- Select the Upgrade table in the center column.
- Note the ActionProperty column in this table.
- Determine if the value in the ActionProperty is used in more than one row of the table.
- When the duplicate row is found, change the value in the ActionProperty field to be a unique value.
- Rebuild the project.
- Select the Direct Editor view.
- Select the Upgrade table in the center column.
- Note the MinVersion and MaxVersion columns in this table.
- For each row, make sure the value in the MinVersion column is less than the value in the MaxVersion column.
- If any rows are found that have higher MinVersion values, change them to be less than the MaxVersion value.
- Rebuild the project.
Additional Information
To perform this validation test, the validation engine needs to examine only the latest version of your setup.
Related Articles
Validator Number Val0001 3Number of Views Validator Number Val0006 3Number of Views Validator Number Val0009 3Number of Views What FlexNet inventory agent and beacon release number corresponds to each product version? 299Number of Views FlexNet Manager for Engineering Applications release numbers and corresponding product versions 49Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago