Summary
This Knowledge base article will explain a error may occur. That some column value is duplicated while migration scirpt is running.Symptoms
This Knowledge base article will explain a error may occur. That some column value is duplicated while migration scirpt is running.The specific error message is:
Adding 'Oracle Unlimited Agreement' to PurchaseProgram table
Msg 2627, Level 14, State 1, Line 3
Violation of PRIMARY KEY constraint 'PK_PurchaseProgram'. Cannot insert duplicate key in object 'dbo.PurchaseProgram'. The duplicate key value is (33).
The statement has been terminated.
This happened at the following section in the cm-migr1010-migprep.sql file.
IF NOT EXISTS ( SELECT 'x' FROM dbo.PurchaseProgram WHERE PurchaseProgramID = 33 and Name='Oracle Unlimited Agreement')
BEGIN
PRINT 'Adding ''Oracle Unlimited Agreement'' to PurchaseProgram table'
SET IDENTITY_INSERT PurchaseProgram ON
INSERT INTO dbo.PurchaseProgram(PurchaseProgramID, Name, PublisherName, Code)
VALUES(33, 'Oracle Unlimited Agreement', 'Oracle','OULA')
SET IDENTITY_INSERT PurchaseProgram OFF
END
Cause
This is bug of current migration script that checking statement before insert is too 'narrow' eg: SELECT 'x' FROM dbo.PurchaseProgram WHERE PurchaseProgramID = 33 and Name='Oracle Unlimited Agreement'In fact either PurchaseProgramID & Name are PK unique column but they can be used with other value of name etc.
The cause can be
1. Either user can manually adding this by a sql update statement
2. This record can be insert by our content library when FNMP system is still in v9.2
Resolution
As the issue is not widely reported so at this stage we believe it's case by case basis, therefore we provide with this KB article for the current resolution of this issue.Roll back the product database before migration point and run below two SQL script
DELETE FROM PurchaseProgram
WHERE Name = 'Oracle Unlimited Agreement'
DELETE FROM PurchaseProgram
WHERE PurchaseProgramID = 33
Kick off another script migration process to observe the original error no longer appear.
Please contact Flexera Technical Support if need any further assistence.
Was this helpful?
Related Articles
"Sync License Reconcile Results" reconcile step may generate invalid license assignments and fail: "Violation of PRIMARY … 6Number of Views BuildFabricatedComputerList step in ManageSoft reader may fail with error: "Violation of PRIMARY KEY constraint 'PK__#Part… 9Number of Views Importing Active Directory domain .actdir file may fail with error if computer names differ only by special characters: "V… 6Number of Views Importing FlexNet inventory agent inventory may fail at LoadSoftwareFileNames step with error: "Violation of PRIMARY KEY c… 4Number of Views Business adapter may fail with error importing data when parent-child asset relationships exist: "Violation of PRIMARY KEY… 4Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago