Summary
This knowledge base article will describe a product defect that FlexNet inventory agent may incorrectly count Oracle Universal Installer (OUI) packages which are located in a backup directory. The article contains the details of the cause and workaround information.
Symptoms
- We have detections of Oracle DB versions that we no longer use. Why is this?
- We are seeing Oracle DB components as in use when there is no Oracle DB on this server any more. Why are they in use?
Cause
Oracle Universal Installer saves a backup of its inventory package before any changes like an uninstall, and our Agent is reading these backed-up OUI packages causing to report uninstalled Applications when they are no longer installed.
Steps to Reproduce:
- Install a Oracle software with Oracle Universal Installer.
- Uninstall the Oracle software using the Oracle Universal Installer.
- You will find a backup folder under the Inventory directory, which is being collected by the Agent.
The backup path should be easy to identify. You can open the agent tracker.log (by default located in C:\Windows\Temp\ManageSoft on Windows devices and /var/opt/managesoft/logs on Unix-like devices) and search for backup or oneoffs to identify the detected XML file.
- Examples for default installation:
- C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\inventory.xml
- C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\comps.xml
- Example for custom install location:
- C:\Oracle\product\11.2.0\OraHome112\inventory\backup\2016-06-23_12-06-41PM\ContentsXML\inventory.xml
- C:\Oracle\product\11.2.0\OraHome112\inventory\backup\2016-06-23_12-06-41PM\ContentsXML\comps.xml
Resolution
It is reported as a product defect referenced FNMS-35281. It affects FlexNet Manager Suite agent from version 2015-2019 R1. This defect has been fixed in FNMS agent 2019 R2 (14.0) and XML files found in backup folders will be ignored.
Workaround
This can be worked-around as follows:
- Open OUI and ensure all the components which are not needed are correctly marked as uninstalled.
- Open the tracker.log for the agent, and search for backup and oneoffs which will display a file path for an XML file located in a backup or oneoffs directory. Open this up and ensure the components do not appear as an XML element.
- Save the file and perform an inventory and reconcile.
Alternatively, the backup or oneoffs directories can be excluded so that the agent knows not to collect inventory from these folders as follows:
- On Windows devices, open the following registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ManageSoft Corp\ManageSoft\Tracker\CurrentVersion] and add the below keys as type string.
- On Unix-like devices, open the agent config.ini (or ndtrack.ini for the light agent) and add under the ini group [ManageSoft\Tracker\CurrentVersion] following the same format as the file.
Name: ExcludeDirectory
Value: */backup;*/oneoffs
Name: ExcludeEmbedFileContentDirectory
Value: */backup;*/oneoffs
Note: This would exclude parsing all file content from backup folders, not just OUI backups.
Additional Information
https://docs.oracle.com/cd/E11882_01/em.112/e12255/b_oui_appendix.htm#OUICG37
Snippet from tracker.log to help identify where the Agent has found this false-positive xml file:
[7/16/2016 8:06:44 AM (G, 0)] {4780} The file 'C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\comps.xml' has been detected as a possible package registry
[7/16/2016 8:06:44 AM (G, 0)] {4780} The file 'C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\inventory.xml' has been detected as a possible package registry
Snippet from trace:
627.9708, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Attempting to parse OUI inventory.xml file: 'C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\inventory.xml' 627.9717, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Not found OUI comps.xml file: 'C:\Oracle\11.2.0\product\11.2.0\client_1\inventory\ContentsXML\comps.xml' 627.9724, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Parsing OUI comps.xml file: 'C:\Program Files (x86)\Oracle\Inventory\ContentsXML\comps.xml' 627.9731, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Parsing OUI comps.xml file: 'C:\Program Files (x86)\Oracle\Inventory\backup\2016-06-23_09-34-34AM\ContentsXML\comps.xml' 627.9749, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Parsing OUI comps.xml file: 'C:\Oracle\product\11.2.0\OraHome112\inventory\backup\2016-06-23_12-06-41PM\ContentsXML\comps.xml' 627.9769, pid 7720 (Inventory/Packaging/OracleUniversalInstaller): Find OUI edition for comps.xml file: 'C:\Oracle\product\11.2.0\OraHome112\inventory\backup\2016-06-23_12-06-41PM\ContentsXML\comps.xml'
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Case id: 00001065
Activity: Status change: 2 hours ago