Summary
Another installation is in progress. You must complete that installation before continuing this one.Symptoms
When running an installation created with InstallShield Express, the following error may occur:
Error 1500. Another installation is in progress. You must complete that installation before continuing this one.
Cause
Setups created with InstallShield Express are built on the Microsoft Windows Installer Service. When the Windows Installer performs a transaction, it creates a registry key called InProgress, which is located at HKEY_Local_Machine\Software\Microsoft\Windows\Installer\InProgress. When the transaction is done, it removes the key. Other installations check for this key before they begin. If the key exists, the installation does not start and produces Error 1500.
Possible Causes
- Msiexec.exe has been launched via a custom action too late in the sequence in an InstallShield Express setup. This causes more than one instance of Msiexec to be run at the same time. More than one instance of Msiexec cannot be run in the execute sequence.
- In some cases, the InProgress key can be left behind if an installation is cancelled forcibly via the Task Manager during a transaction.
- There is a mutex called _MsiExecute that prevents an installation from running. Sometimes other processes hold it. One such process is a MS Office service called the Office Web Server Notification Service (owstimer.exe) that sometimes holds onto the _MsiExecute object, causing installations to be locked out.
Resolution
- The custom action must be invoked earlier in the sequence. Follow these steps to move the custom action.
- Open the Custom Actions view.
- Identify the custom action in the center panel that launches the file Msiexec.exe or launches another Windows Installer-based setup.
- Note the Invoke property in the property sheet at right.
- Change this value to anything before the "After Ready to Install dialog" option. For example, the "After Install Welcome dialog" option would be an ideal option to select as it comes before "After Ready to Install dialog" in the drop-down list.
- Repeat the above steps for all other custom actions that launch the file Msiexec.exe or another Windows Installer-based setup.
- Rebuild the installation to include the changes.
- To get rid of the InProgress key, first try rebooting. If this does not work, download the Windows Installer SDK. There is a tool that comes with it called MsiZap.exe. Run this EXE from the command prompt by typing 'msizap p' to remove the key.
- To find out whether or not a process is holding _MsiExecute, obtain a tool that allows you to view handles and processes, such as Handle, and search for _MsiExecute, then take steps to stop that process. Handle is a free tool available from Sysinternals. Information on how to use this utility is provided on the download site.
Note: If owstimer.exe is found in the Task Manager, set the service to start manually (it starts automatically by default) in the Service Control Manager, then reboot. On WinNT systems, the Service Control Manager is accessible via the Control panel. On Window 2000/XP systems, the Service Control Manager is accessible via the Administrative Tools section, which is accessible via the Control Panel.
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Case id: 00001065
Activity: Status change: 2 hours ago