Summary
Information about windows installer errorSymptoms
Error 1606 is a Windows Installer error that is displayed in the following format:
Error 1606. Could not access network location [2].
Cause
The MSI Standard Action, CostFinalize, is unable to resolve a value of an entry defined in the directory table of the MSI package due to an invalid path.
Example of a valid path = C:\My Pictures
Resolution
- Select the Setup Design view.
- Verify that the Destination field for each component or feature is valid.
- If any destinations are not valid, change this value to reflect a valid path.
- Rebuild the release after any modifications have been made.
B. An invalid path has been assigned to the value of INSTALLDIR under General Information > Product Properties. Select the General Information > Product Properties view.
- Verify that the path specified in the INSTALLDIR field is valid.
- If the path is invalid, change this value to reflect a valid path.
- Rebuild the release after any modifications have been made.
Verify that the values under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders all have valid paths. If the paths point to a remote computer or mapped drive, verify and establish a connection to the remote computer to which the target location refers.
To access this key, use these steps:
-
Click Start and click Run.
-
In the Open box, type regedit and click OK.
-
Locate and click the key.
-
In the right pane of the registry editor window, check the value of each folder key referenced here.
-
If there are invalid paths referenced, these values must be changed to point to valid drives.
-
Close the Registry Editor and Reboot the machine.
-
Rerun the installation.
D. A property listed in both the Property table and Directory table has been assigned an invalid path in the Property Manager.
- Open the Property Manager.
- Verify that one of the properties is also listed in the Directory table, which can be accessed via the Direct Editor. If no properties in the property table match any of the Directory table listings then Cause 4 is not the source of the issue.
- If a property in the Property Manager does match one listed in the Directory table, verify that the property has been assigned a valid path.
- If the path is invalid, the property must be deleted or a valid path must be assigned to it.
-
Rebuild the release after any modifications have been made.
If the value of INSTALLDIR or DATABASEDIR under the General Information view is incorrect, this error can occur.
An example of a incorrect value is an invalid path or folder name (for example, testfolder, C;). Examples of correct values are C:\testfolder, [ProgramFiles]\test, and HKEY_LOCAL_MACHINE\Software\test\
Make sure that the path pointed to by INSTALLDIR and/or DATABASEDIR under General Information is valid. Make sure that DATABASEDIR variable in the General Information view does not point to a path specified by a registry value (for example, HKEY_LOCAL_MACHINE\Software\Test). If it does, change the value of DATABASEDIR to a predefined variable or an absolute path. Follow the steps below to correct the issue. This example uses INSTALLDIR. The same steps can be followed for DATABASEDIR:
a. Open the General Information view and click the ellipsis (...) in the INSTALLDIR field. This launches the Set INSTALLDIR dialog.
b. Select a predefined folder like ProgramFilesFolder or another folder and click OK. This populates the selected folder as the value of INSTALLDIR.
c. Click the ellipsis (...) in the INSTALLDIR field again to launch the Set INSTALLDIR dialog.
d. Scroll to the folder or registry path that was causing the error message.
e. Right-click on the folder or registry path and select Delete.
f. Click OK to save these changes.
g. Rebuild your release to eliminate the error message. Launch regedit.exe from your Start / run command to launch your registry. In the registry, go to the following location and make sure that the paths to all the folders are valid and exist on the system. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders.
This error has also occurred if the path specified by the following registry keys is not valid. Following are some other registry keys that one should verify in case the above error message occurs on the system:
-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
-
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinNT\CurrentVersion (only for SystemFolder on NT-based systems)
Additional Information
MSI error 1606 is generated by the CostFinalize standard action. One purpose of CostFinalize is to verify that all target directories are accessible with write permission before allowing the installation to continue. The CostFinalize Standard Action is documented in the Windows Installer Help Library topic CostFinalize Action. Error 1606 is documented in the MSI Help Library topic Windows Installer Error Messages.
-
The MyPicturesFolder property is documented in the Windows Installer Help Library topic "MyPicturesFolder Property".
-
256986 Description of the Microsoft Windows Registry
Important: Using the Registry Editor incorrectly may cause serious problems. Microsoft cannot guarantee that with incorrect use of the Registry Editor problems can be solved. Also, Microsoft warns that caution should be taken when using the Registry Editor.
- Additional articles on Error 1606 can also be found in Microsoft's Knowledge Base:
- 313257 "Windows Installer error 1606" error message when you try to start Help in Office 2000 programs
- 313928 "Cannot remove previous version" error message when you install Microsoft Works or Microsoft Picture It!
- 315352 "Error 1606. Could not access network location <common administrative tools>. All users\" error message when you install a program
- 307683 Error Message When You Install Plus! for Windows XP: "Error 1606. Could Not Access Network Location"
- 313257 "Windows Installer error 1606" error message when you try to start Help in Office 2000 programs
Related KB Articles
Could Not Access Network LocationRelated Articles
Windows Installer Error 1606 3Number of Views Windows Installer Error 1310 3Number of Views Windows Installer Error 1907 5Number of Views Windows Installer Error 2732 6Number of Views Windows Installer Error 1706 47Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago