Summary
Service '[SERVICE]' could not be installed. Verify that you have sufficient privileges to install system services.Symptoms
Error 1923 is a Windows Installer error that occurs only at run time and is displayed in the following format:
Service '[SERVICE]' could not be installed. Verify that you have sufficient privileges to install system services.
[SERVICE] resolves to the name of the service.
Cause
Cause 1
An option is applied that is not appropriate for the service being installed. The User Name, Password, Dependencies, or Load Order Group field likely contains a value that is not compatible with the service being installed. For example, User Name and Password fields specify incorrect values.
Cause 2
A driver service is being installed. File system driver services and driver services are not supported by the Windows Installer.
Resolution
Resolution 1
- Select the Setup Design view.
- Locate the component containing the service displayed in the error message. If you are not sure which component the service is associated with follow these steps:
- Select the Direct Editor view.
- Click the ServiceInstall table.
- Type CTRL+F and search for the name of the service displayed in the error message.
- Once the entry is found, take note of the Component column's value. This is the name of the component that contains the service.
- Select the Direct Editor view.
- Open the component's Advanced Settings | Install NT Services section.
- Click the name of the service displayed in the error message found on the right side.
- Analyze the fields and verify that each is appropriate for your service. You must be familiar with the service in order to appropriately determine which field settings work successfully with your service. Contact your service vendor for the service details.
- Change the settings accordingly.
Resolution 2
A custom script must be written that uses a setup API to install the driver service. This script can then be launched via a custom action.
Related Documents
Custom Action Types
Additional Information
For more information on Windows Installer messages, see Windows Installer Help Library topic Windows Installer Error Messages.
For more information on the ServiceInstall table, see Windows Installer Help Library topic ServiceInstall Table.
Related KB Articles
Q102851Was this helpful?
Related Articles
Windows Installer Error 1310 3Number of Views Windows Installer Error 1907 5Number of Views Windows Installer Error 2732 6Number of Views Windows Installer Error 1706 47Number of Views Windows Installer Error 1406 13Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago