Issue
Customer cannot edit web applications or custom fields
Environment
Snow License Manager 8.X
Analysis
- Add a custom field or web applications
- Try and delete the items
- Items are unable to be deleted or edited and saved
- Export of F12 developer tools (Network selection) indicates a '405 - Method Not Allowed' error when clicking on the close buttons
Resolution
- It seems that WebDAV is failing when calling the DELETE method.
- You can resolve this by removing / disabling WebDav as long as this is not required for other purposes.
Method 1
- Open up IIS - On the Site Snow License Manager you will find Handler Mappings and Modules. List the contents and remove the WebDav entries in both.
- Optional (In the section Request Filtering Behaviour, set Allow Verb Filtering to False)
- Restart IIS.
Method 2
- Open up web.config in C:\Program Files\Snow Software\Snow License Manager\web and add the lines:
<system.webServer>
<modules>
<remove name="WebDAVModule" />
</modules>
<handlers>
<remove name="WebDAV" />
</handlers>
</system.webServer>
- The modules and handlers node should already be present so just add the highlighted row (<remove name="WebDAV" />).
- Don't forget to restart IIS.
- To make sure it's disabled navigate to webDAV authoring for License Manager site and click Disable.
Cause
WebDAV is causing an issue when trying to call the DELETE method.
Source: Stack Overflow
Source: Stack Overflow
Was this helpful?
Related Articles
Unable to edit or delete custom fields in Snow License Manager 78Number of Views FAQ: Can Custom fields have the same Name as one of the Standard fields in Snow License Manager? 12Number of Views How to: Check logs for Scheduled reports in Snow license Manager 46Number of Views How To: Web Applications configuration & troubleshooting in Snow License Manager 121Number of Views Snow License Manager: How to look for duplicates 179Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago