This article addresses issues related to advanced security policies and zero trust software that may prevent Snow software from functioning correctly.
Issue
- Advanced security policies preventing the Snow Agent from executing.
- Snow infrastructure communication is blocked.
- Snow browser extensions are blocked.
Cause
Many companies are implementing advanced security policies, which can include changes to TLS and cipher suite settings at the network level, and the implementation of security policies such as FIPS. It is crucial to test these policies and any associated security software. Without proper testing, the Snow Agent and its network traffic may be mistakenly identified as malicious.
Examples of zero trust security software that have been known to prevent the Snow Agent from executing or communicating correctly include:
- CrowdStrike Falcon Zero Trust
- Illumio
- Tanium
NOTE: This is not an exhaustive list. Other security software and strict network and group policies may also cause similar issues.
- Engage with your security team: If you suspect that a third-party security product or policy is causing issues with the Snow Agent, consult your security team.
- Vendor engagement: If you cannot determine the root cause, contact the security software vendors for further troubleshooting. Flexera support cannot advise or assist with all security software, as many settings could affect the product. Any changes will need to be agreed upon with your security team.
- Log analysis: If there are issues running the Snow Agent, particularly in a Windows environment where Snow uses PowerShell scripts to gather key data, use logs from the Snow Agent and the timestamp of errors to match against any security product logs. Windows events log can help with troubleshooting networking and application level issues. HAR files are useful to get a time stamp when there are Web GUI issues.
- Testing: It is highly recommended to test the Snow estate when implementing security hardening measures.
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