Summary
When attempting to install the MSI 3.1 engine on a target machine, InstallScript MSI projects may fail with an error 1601 or 1719 indicating that the Windows Installer Service is unavailable at the time the installation is launched.Symptoms
When attempting to install the MSI 3.1 engine on a target machine, InstallScript MSI projects may fail with an error 1601 or 1719 indicating that the Windows Installer Service is unavailable at the time the installation is launched.
Cause
This occurs as a result of a timing issue where the Windows Installer engine is not ready when the InstallScript engine attempts to access it.Workaround
As a workaround to this issue, do not supress the Windows Installer 3.1 engine reboot when using the InstallScript MSI project type.Was this helpful?
Related Articles
Variable SETUPEXEDIR returns blank when running a Patch Update 3Number of Views InstallScript MSI Major Upgrade Results in "Setup Launcher Unicode Has Stopped Working" 10Number of Views Perform Major Upgrade of InstallScript MSI Project with Basic MSI 3Number of Views Warning-7065 Windows Installer 3.1 Engine could not be found, while creating a patch and "Error reading setup initializati… 11Number of Views Windows Installer Property PATCH - Working With Conditions in a Basic MSI Specific to a Patch Install 3Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago