Summary
The ESD service caches settings, including service now connection settings. If the settings are changed in the main App Portal site, then it may be necessary to restart the ESD Service.Symptoms
Upon saving ServiceNow Integration settings in App Broker, catalog items are not being synced. Both the "Test" and "Create Default ITSM Operations" buttons indicate that the connection settings are valid; however, the following error is logged in the ServiceNowIntegration.log:Failed to connect to ServiceNow to create Catalog. Error Details:Please provide the ServiceNow instance Url and Username
Cause
This may occur if no credentials are specified, or if credentials have been changed. If the message "Please provide the ServiceNow instance Url and Username" is logged in ServiceNowIntegration.log, then this would typically indicate that the ESD Service has no credentials, or the wrong credentials cached.Resolution
Saving the correct credentials, then restarting the ESD Service, should resolve the issue.Additional Information
For additional information on importing catalog items into ServiceNow, see Importing Catalog Items into ServiceNow in the App Portal / App Broker for ServiceNow Administration Guide.Was this helpful?
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Case id: 00001065
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