Summary
Listing of possible causes and resolutions for build time error -1014Symptoms
When building an InstallShield project, the following error may occur:
Error -1014: Cannot rename directory [2]
[2] is a placeholder that contains the full path to the directory that causes this error.
Cause
This error occurs when the folder specified in the error message is locked, and InstallShield is trying to rename this folder during the build process. This folder can be locked for any of the following reasons:
- A file within that folder, or the folder itself, is currently open in the Windows Explorer.
- Another application is using that folder, or a file within that folder, thereby locking the folder.
- The InstallShield IDE has been opened multiple times, and another copy of the IDE is using that location.
- The release has been corrupted; therefore, the folder cannot be renamed.
Resolution
One or more of the following steps may resolve the issue.
- Close down all Windows Explorer windows and rebuild the installation. If the location specified in the error is currently opened within an Explorer window, that folder is locked by Windows and cannot be accessed by InstallShield.
- Close all other running applications and utilities, including virus scanners. If any of these processes are accessing the folder specified in the error message, this error occurs. For example, if Norton VirusScan is currently running and scanning that particular folder, this error can occur during the build process. Rebuild your setup after closing these processes.
- Make sure only one instance of the InstallShield IDE is currently open. If multiple copies are open, close all other copies so only one instance of the InstallShield IDE is open. After doing this, rebuild the setup.
- If the error still occurs after the above steps, reboot the machine. In rare instances, services or other processes could be locking that folder that cannot be manually shut down. Rebooting the machine frees up these resources and allows the build process to complete successfully.
- If the error persists despite the previous suggestions, this release may have been corrupted. InstallShield users can select Build > Release Wizard to build a new release. When building a release, select a new release name. Express users can select Build > Build <Release Name>.
Additional Information
For additional information on the steps required to build a release, refer to the InstallShield Help Library topic Working with Releases.
This error is briefly documented in the InstallShield Help Library topic Build Errors and Warnings.
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Case id: 00001065
Activity: Status change: 2 hours ago