Summary
Error -6258: An error occurred extracting digital signature information from file [1]. Make sure the digital signature information provided in the IDE is correctSymptoms
When building an InstallShield project, the following error may occur:
"Error -6258: An error occurred extracting digital signature information from file [1]. Make sure the digital signature information provided in the IDE is correct."
[1] is a placeholder that contains the file being used to extract the digital signature information.
Cause
This error is known to occur for the following reasons:
- The digital signature password provided during the build is incorrect.
- The digital signature files have expired and are, therefore, invalid. Digital signatures are only valid for a limited time and can cause this error when expired.
- The digital signature syntax entered into the "Build Your Release" view is incorrect.
Resolution
-
Verify the password entered for the digital signature during the build process is accurate. Note this password is case sensitive. If in doubt, contact the digital signature issuer, such as VeriSign, for the correct password.
Another way to verify that the password is accurate is to manually call the utility signtool.exe to sign a file. This file is located, by default, in <PROGRAMFILES>\InstallShield\Express [n]\Support. Additional information on the command-line parameters to pass to digitally sign a file can be found in the Netscape Signing Tool article. If the signing process fails using this method as well, it is safe to assume that the password is incorrect.
Note: [n] contains the version of InstallShield Express being used, for example, Express 5.0
- If the digital signature has expired, contact the digital signature issuer, such as VeriSign, to purchase a new digital signature.
Another option to determine if the password is expired can be found in Resolution A. The signtool.exe utility can be used to manually sign a file to ensure it works correctly. This would easily determine if the problem is caused by an expired or incorrect password or for some other reason.
- The information entered in the "Build Your Release" view must be accurate for the signing to complete properly. Make sure the URL specified is accurate, and the .spc and .pvk files specified are located in the path indicated. This information can be found in the "Build Your Release" view by selecting WebDeployment and noting these values in the right panel under the heading "Sign Media (for Setup.exe and Internet Explorer)".
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Case id: 00001065
Activity: Status change: 2 hours ago