Summary
The Compliance Import fails with the error "Cannot open database "" requested by the login. The login failed.", this can been seen in the importer log file.
Symptoms
The Compliance Import fails with the following error message listed in the "Importer.log", when running the import manually this will also fail and produce the same error message.
Error:
" Importing from '<DatasourceName>' [type: <DatasourceType>
<TimeStamp>[FATAL] The import process has failed with the following error (use -verbose to see error details):
Error: Cannot open database "<DatabaseName>" requested by the login. The login failed.
Login failed for user '<AccountName>'.
There is a possible connection type mismatch: check that the database is of the correct connection type
Cannot open database "<DatasourceName>" requested by the login. The login failed.
Login failed for user '<AccountName>''."
Cause
This error is caused by the credentials used by FlexNet Manager Platform not being able to access the datasource listed in the error message.
Resolution
To resolve the connection issue ensure the credentials used are correct for the datasource, this can be verified on the "Connections" tab by right clicking on the "FlexNet Manager Platform" node and selecting "Properties" or if a Beacon is used on the "Inventory Systems" tab from within the BeaconUI.
In addition to this, the following should also be verified:
-The account listed in the error is not locked.
-The account listed in the error has the correct permissions to access the datasource.
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Case id: 00001065
Activity: Status change: 2 hours ago