Summary
This article will explain how to overcome the lmadmin startup error: "Could not open configuration file C: Program Files (x86)\\/lmadmin/conf/httpd.conf: The system cannot find the path specified." when placing files that are user customised in the ProgramData folder.Symptoms
When creating an lmadmin installer that has to be compliant with Windows 7 Client Software Logo installation guidelines, files that are user customised need to be placed in the ProgramData folder. This includes the "logs" and "conf" folders. However, when moving these files and running lmadmin with the "-logDir" and "-configDir" properties, these don't seem to be updating the server.xml file with the new locations, so lmadmin won't start manually or as a service, and in the "web.log" the following error is thrown:"lmadmin: Could not open configuration file C:Program Files (x86)\\<vendorName>lmadmin/conf/httpd.conf: The system cannot find the path specified."
Cause
Running lmadmin with the "-logDir" and "-configDir" properties, doesn't seem to be updating the server.xml file with the new locations, and lmadmin fails to start.Resolution
The latest FlexNet Publisher toolkit release (v11.13.1.3) resolves this issue by introducing a new command-line option called "cacheDir".Example of use:
lmadmin -cacheDir "C:\ProgramData\<vendorName>\lmadmin"
Was this helpful?
Related Articles
"The system cannot find the file specified" when running ARL update 16Number of Views "The system cannot find the path specified" error when performing a Snow Agent scan 23Number of Views "Get Azure VM Instances" Azure import reader step may fail with error: "Could not load file or assembly '[...]' or one of … 10Number of Views 'The system cannot find the file specified' error when performing Remote Execution/Zero-Touch Inventory 8Number of Views Adoption not working with 'The system cannot find the file specified' error is the beacon and target adoption machine are … 13Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago