Symptoms
This article explains the Flexnet Operations Application deployment or Deploy All is taking a long time than expected, how to find what was the cause and how to fix it.
Diagnosis
If Deployment is not failed but it was taking more time than expected or if you are seeing the time to complete the deployment is increasing every new deployment then there might be lots of Import/Export files or Data Extract files in the ADMN directory and .prd files in the prd directory located in this below path
C:\FlexNetOperations\components\wildfly\standalone\deployments\flexnet.ear\flexnet-data\data\ADMN
C:\FlexNetOperations\components\wildfly\standalone\deployments\flexnet.ear\flexnet-data\data\prd
Solution
To fix this issue, try to clear these files after taking backup regularly under the below listed path;to speedup the Deployment and reduce the deployment time
C:\FlexNetOperations\release\flexnet-data\data\ADMN
C:\FlexNetOperations\release\flexnet-data\data\partdatatemp
C:\FlexNetOperations\release\flexnet-data\data\prd
C:\FlexNetOperations\release\flexnet-data\data\wrkdatatemp
- Where the ADMN directory will have the Import/export and data extract files if the file location configured as default.
partdatatempdirectory will havepartnumberrelated XML temp fileswrkdatatempdirectory will haveWebRegKeysrelated XML temp files andprddirectory will have FNP license activation related prd temp files, read more about prd files click here
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago