Summary
This article will describe a product defect that computer inventory were successfully read from Inventory Source (IM,SCCM various source), but not able to find in FNMP All Inventory page.Symptoms
There is a defect introduced in product version 2015 R1 -- R2 SP2. The issue is that inventory computers exist in the inventory source (Inventory Manager, SCCM, ADDM etc), but they do not show up in the All Inventory page from UI.Other symptoms including:
1. Devices exist in the ZIP package from inventory source import, but do not show up in the Inventory in FNMP
2. Devices listed under application properties but not all inventory
3. Inventory stuck in the database as 'Awaiting inventory' in ComplianceComputer table
This article also includes a patch for on premise customer.
Cause
The cause was the importer incorrectly update the computer , even the Computer Status is 4 -- Awaiting Inventory, but not update the status back to 1 'New'. So user is unable to find the machine from product UI.The following steps can be used to reproduce the issue:
1. Import inventory from inventory source eg: SCCM
2. Create asset from inventory
3. Unlink inventory from asset
4. Delete inventory -- then the ?Dummy? ComplianceComputer row created
5. Re-import inventory from SCCM: ComplianceComputer updated with inventory information, but not the ComplianceComputerStatusID
Resolution
The permanent fix will be included in 2015 R2 SP3 release in mid of Feb 2016.Workaround
For the affecting customer if you are using On-premise solution , please follow the below steps for applying the patch in the attachment:1. Do a SQL database full backup (in case we need rollback)
2. Unzip the patch.zip from attachment
3. Run FNMS-29156.sql
4. Run FNMS-29251.sql
5. Run another inventory import, the affected inventory computer should be re-appeared in the UI
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|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
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Case id: 00001065
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