Summary
Issue where the Disk Space Check always reports the available free space on the root partition, /, instead of the targeted partition
Symptoms
During runtime, the disk space check which reports the disk space available, always reports the value from the file system mounted on the "/" directory. This happens even when the installation folder is changed to another directory, for example /home. This issue can also cause the installation to fail if there isn't enough space at "/" and the disk space check fails, even if the install folder chosen should have enough space.
Cause
This problem has been reproduced and determined to be an issue in our software. The issue only occurs for certain 'df' outputs returned by the shell and is not specific to the platform used.
Steps To Reproduce
- Create a new InstallAnywhere project
- Make sure a Choose Install Folder panel or console is included in the Pre-Install sequence
- Run the installer on the target machine with a problematic 'df' output
- Set install location to a folder under /home
- Proceed to Pre-Install Summary and note the Available space under Disk Space Information is incorrect as it displays the disk space for the "/" partition
Resolution
This issue has been submitted to our Engineering team as Issue# IOJ-1866007. Our Engineering team is investigating this issue, but at this moment, there is no estimated time frame for when it will be fixed.
Workaround
Turning off CHECK_DISK_SPACE allows the install to continue: Disk Space Check
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Case id: 00001065
Activity: Status change: 2 hours ago