Summary
The error Version of vendor daemon is too old. (-83,21049:104 "Connection reset by peer") is seen after upgrading the Flex Enabled Client.
Symptoms
Errors similar to:
9:35:08 (flexera) Request denied: Client (11.14) newer than Vendor Daemon (11.13). (Version of vendor daemon is too old. (-83,21049:104 "Connection reset by peer"))
are seen after upgrading the FlexNet Publisher version of the client application.
Cause
The version compatibility rules regarding FlexNet Publisher elements are defined in the Version Compatibility Between Components section of the FlexNet Publisher License Administration Guide.
Version Compatibility Between Components
In general, always use the latest version of lmadmin, lmgrd, lmutil, and lmtools, all of which are available from Revenera, to exploit the enhancements available in the most recent versions of FlexNet Licensing.
However, some enhancements require a vendor daemon built with a newer version of FlexNet Publisher, and yet others require a FlexEnabled application built with a newer version of FlexNet Publisher. Contact your software publisher for the latest version of their vendor daemon.
The rules about FlexNet Licensing component version compatibility are summarized as:
- Version of lmutil/lmtools must be >=
- Version of lmadmin (or lmgrd), which must be >=
Note: lmadmin can only be used with components with a version of 9.2 or later. - Version of vendor daemon, which must be >=
- Version of the client library linked to the FlexEnabled application, which must be >=
- Activation utility, which must be >=
- Version of license file format
Except for the license file, use lmver to discover the version of all these components. For the vendor daemon, lmgrd, and lmutil, you can also use the -v argument to print the version.
The 'error' message reported was introduced in version 11.12.1.2 when FlexNet Publisher was upgraded to enforce this rule. This is an extract from the release notes:
Version Compatibility
The FlexNet Publisher support statement is: version (vendor daemon) >= version (client). Previously, the license server did not verify the version of FlexNet Publisher client during checkout process, when the client version was greater than the server version. This could result in misleading errors, making it difficult to determine that the root cause was that the vendor daemon had not been upgraded.
Now, when a checkout request is sent by a client that has FlexNet Publisher version greater than vendor daemon then error -83 (LM_SERVOLDVER) will be returned.
Resolution
Upgrade the license server elements to at least the same version as the client application
Related Articles
How Can I Access The License File Location Passed To The Vendor Daemon From The Vendor Daemon Code? 8Number of Views Error: -97,121 - LM_VENDOR_DOWN - "The desired vendor daemon is down" 22Number of Views Vendor Daemon Can't Talk to lmgrd (Cannot Read Data from License Server System (-16,287)) 16Number of Views Is There Any Way to Increase or Decrease the lmgrd and Vendor Daemon's Log Verbosity? 8Number of Views Vendor Daemon, License Server or Feature is missing when editing or running a report 6Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago