Summary
Importing multiple SCCM datasources using the Beacon fails with a "constraint FK_ComplianceComputer_ComplianceDomain" error.Symptoms
When performing an import for SCCM from an Inventory Beacon this will fail with the following error message:
"The MERGE statement conflicted with the FOREIGN KEY constraint "FK_ComplianceComputer_ComplianceDomain". The conflict occurred in database "<DatabaseName>", table "dbo.ComplianceDomain_MT", column 'ComplianceDomainID'. The statement has been terminated. Added 0 Computers from the source database connections. Computer: Added 0 Computers from the source database connections.".
Cause
The error message is caused by a known issue when importing multiple SCCM datasources using an Inventory Beacon.
Resolution
The issue reference number for this is "FNMS-26880" and this is currently scheduled to be permanently resolved in FlexNet Manager Suite 2015 R2 SP1.
Workaround
Attached to the KB is the current workaround for this issue, the steps below can be used to apply the fix.
-Download the updated Domain.xml in the attached zip "DomainUpdated-FNMS-26880.zip".
-Backup the current Domain.xml from the default location "C:\programdata\flexera software\compliance\importprocedures\writers\Domain.xml" .
-Replace the Domain.xml with the file extracted from the zip.
-Re-run the failed imports.
Related Articles
AddVDIGroups inventory import step may fail with error when importing data from multiple VMware Horizon connections that h… 4Number of Views SCCM failed with an inventory data import error issue 6Number of Views Compliance Import fails with the error "Cannot open database "<Databasename>" requested by the login. The login fail… 28Number of Views Business adapter may fail with error importing data when parent-child asset relationships exist: "Violation of PRIMARY KEY… 4Number of Views Known Issue: “Create license allocations from ImportedSoftwareLicenseAllocations” import step may fail with “Violation of … 6Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago