Summary
InstallShield provides the option of registering an InstallScript Object built on a different machine with the current version of the InstallShield IDE. If the Object is not present in the "Objects" view, you would need to right-click on any existing Object, choose "Advanced", then select "Register new Object" and follow the prompts.Symptoms
InstallShield provides the option of registering an InstallScript Object built on a different machine with the current version of the InstallShield IDE. If the Object is not present in the "Objects" view, you would need to right-click on any existing Object, choose "Advanced", then select "Register new Object" and follow the prompts.
This option should not be used for InstallScript Objects built with older versions of InstallShield as it will not create a usable Object.
Cause
This behavior is due to the fact that InstallScript Objects must be built with the same version of InstallShield being used to consume the Object.
Resolution
The "Register New Object" option will show an appropriate error message if an attempt is made to register an object built with a previous version using this option. Rebuild the InstallScript Object in question in the latest version of the InstallShield IDE you're currently using. You will then be able to register it successfully in the IDE.
Additional Information
Additional information on distributing an InstallScript Object can be found in the article entitled Distributing an Object in the InstallShield Help Library.Was this helpful?
Related Articles
lc_vsend explained in detail 18Number of Views SVM Agent Scan Types Inspection Explained 6Number of Views The User Flow CSV Export Explained 14Number of Views InstallAnywhere 2022 Public Hotfix A - Project upgraded to InstallAnywhere 2022 from an older version skips a panel in the… 4Number of Views Relation of SIGN and SIGN2 in License File With Reservation in Options File 10Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago