Summary
This article discusses receiving a SignTool Error while building an InstallShield 2014 project.Symptoms
While building with InstallShield 2014, a build error like this SignTool Error is generated:Successfully signed: [1]
SignTool Error: An error occurred while attempting to timestamp: [1]
SignTool Error: An error occurred while attempting to timestamp: [1]
SignTool Error: An error occurred while attempting to timestamp: [1]
ISDEV : warning -1027: A warning occurred while signing setup.exe. See the build log for details.
[1] is a placeholder that contains the filename, such as setup.exe, that could not be signed.
Cause
This issue may be caused by an incorrect entry for the following entry in the InstallShield <IS_2014_HOME>\Support\0409\Settings.xml file, where <IS_2014_HOME> is the location where the copy of InstallShield 2014 was installed:<DigitalSignature Timestamp="http://timestamp.verisign.com/scripts/timstamp.dll"/>
Resolution
Caution: The following instructions require that you modify the Settings.xml file that is installed with InstallShield. This file contains critical data; if it is edited incorrectly, it can cause InstallShield to fail to work. Use extreme care when editing this file.
Please follow these steps:
1. Close InstallShield.
| 2. | Find the Settings.xml file that is installed with InstallShield. Settings.xml is installed in one of the following locations, depending on which language version of InstallShield you are using: |
| ? | English?InstallShield Program Files Folder\Support\0409 |
| ? | Japanese?InstallShield Program Files Folder\Support\0411 |
| 3. | Create a back-up copy of the Settings.xml file, in case you later need to revert to the original version. |
| 4. | Use a text editor or XML file editor to open the Settings.xml file. |
| 5. | Search for the <DigitalSignature> element. It looks something like this: |
<DigitalSignature Timestamp="http://timestamp.verisign.com/scripts/timstamp.dll"/>
| 6. | To override the timestamp server with a different one, set the value of the Timestamp attribute to the appropriate URL. |
To disable timestamping, use an empty value for the Timestamp attribute:
<DigitalSignature Timestamp=""/>
Note: Disabling timestamping may affect how long your digital signature is considered to be valid.
| 7. | Save the Settings.xml file. |
| 8. | Ensure that your XML code is well formed; if it is not well formed, you may have problems using InstallShield. In most cases, you can identify improperly formed XML code by opening the Settings.xml file in Internet Explorer. You should be able to expand and contract the major elements of the file; if you cannot, check the code for errors. |
Whenever you build a release that includes digital signature information, InstallShield sets the timestamp according to the setting that you configured.
Additional Information
See this Changing the Timestamp Server for Digital Signatures HelpNet article for more information.Related Articles
Reactivation Process for InstallShield 2014 & Later 35Number of Views HOTFIX: Japanese ISCmdBld.exe output displays Japanese characters incorrectly during build process. 6Number of Views Verbosely Log the InstallShield IDE or InstallShield Standalone Build (SAB) 16Number of Views 日本語版InstallShield 2014でStandalone Buildを実行すると結果が文字化けする。 3Number of Views InstallShield 2014 Known Issues 4Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago