Summary
There is a problem with this Windows Installer package. A script required for this install to complete could not be run.Symptoms
When running an InstallShield Express project, the following error occurs:
Error -1720: There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action [2] script error [3], [4]: [5] Line [6], Column [7], [8].
The numbers in brackets [ ] are placeholders for the error-specific information that appears in the error message.
Cause
This is a general error message that indicates that a script-based custom action has failed. This can occur with VBScript custom actions.
This error can occur for any of the following reasons:
- An error has occurred within the script that the custom action launches.
- The script has been deleted or moved from the location where the custom action expects to find it.
Resolution
- Debug the script contained within the custom action. As it is VBScript, run this code manually outside of InstallShield Express and make sure it works correctly.* If the script fails for any reason, error 1720 occurs. Therefore, debugging the script is invaluable in determining if the script is failing unexpectedly.
*Note: Any MSI-specific functionality in the script will not work correctly if run outside of InstallShield Express. In this situation, it is recommended to comment out any MSI-specific code as a test to make sure the other code works correctly. If the MSI-specific functionality is critical and cannot be commented out, insert this code into a new InstallShield Express project and test it in this situation.
- Make sure the script is in the location where the custom action expects to find it. To verify this, follow these steps:
- Select the Custom Actions view.
- Select the custom action specified in the error message.
- Make sure the "Source Location" and "File Name" fields in the right panel are accurate.
- Rebuild the installation.
For example, if the file is Installed with the product, make sure that the file was installed properly to the target machine and is in the correct location.
- Select the Custom Actions view.
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Case id: 00001065
Activity: Status change: 2 hours ago